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DIPPER STICK WITH BUCKET TUTORIAL (PROCESSNET GENERAL)

Chapter

Overview

Task Objectives

ProcessNet is a programming tool based on the .NET framework. It uses classes and
variables in the same way as Microsoft Visual Studio does. Therefore, you can use a vast
range of programming techniques with ProcessNet. In this tutorial, you will learn how to use
ProcessNet to create Windows Forms (WinForms), which are user interfaces based on

the .NET framework. You can use WinForms to automate the modelling, analysis, and
plotting processes in RecurDyn.

» Creating a user interface using WinForms

» Automating model creation using a CAD file

» Using ProcessNet functions in classes other than ThisApplication

= Automating modelling, analysis, and plotting processes using dialog windows
» Using Microsoft Visual Studio instead of VSTA

Prior Learning Requirements

The model used in this tutorial is based on the Dipper Stick with Bucket, a DOE & Batch
simulation tutorial included in the RecurDyn tutorials. Therefore, before starting this tutorial,
you must have already completed the Dipper Stick with Bucket tutorial. Also, follow the
ProcessNet Dipper Stick with Bucket (VSTA) tutorial to understand ProcessNet
processing.

Prerequisites

You must be well acquainted with ProcessNet VSTA and the Dipper Stick with Bucket
tutorial or have performed comparable tasks. Also, you must have basic knowledge on
physics.
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Task Duration (minutes)
Starting ProcessNet 5
Creating a Dialog Window 15
Automatic Model Generation through 30

Code

Analyzing a Model 10
Creating a Plot Automatically 10

Total 70

Estimated Time to Complete this Tutorial

This tutorial takes approximately 70 minutes to complete.
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Chapter

Starting ProcessNet General

Task Objectives

To learn how to start ProcessNet General in RecurDyn.

&’ Estimated Time to Complete this Task

5 minutes
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Starting RecurDyn

To start RecurDyn: Start RecurDyn x
~ New Model
1. Run RecurDyn. Nome | MEEEH |
The Start RecurDyn d|a|og Wmdow Unit» 1VI\‘IMKS(M|Illmeten’KlIogram/Newton/Second) ;Vl ‘ Setting ‘
appears. gy Y -]
[ o |
2. In the Name field of the New Model
pane, type Excavator. Open Model [ Browse |
Set the Unit tO MMKS. Recent Models - ‘Icons F}
Click OK to create the new model. '
-

4WD_Loader.rdyn 4WD_Loader_Start.rdyn 4WD_Loader.rdyn

Show ‘Start RecurDyn' Dialog when starting

To save the model:

In the File menu, click Save As and save the model as Excavator.rdyn in the folder you
want.

Starting ProcessNet

To start ProcessNet:

ProcessNet General does not provide the Integrated Development Environment (IDE).
So, an IDE program needs to use it. If you don't have the program, we recommend to use
Visual Studio Expression version supported from Microsoft.

1.

To open the ProcessNet integrated B stat Page - Microsot Visuol Stusio

. File | Edit  View  Debu Team  Tools  Architecture  Test  Analyze  Window  Hel
development environment (IDE), execute  [h s csen ]
the Visual Studio program. (Visual 2 Lo Mase S

ose W Team Project.

Studio 2015 Expression version is used Pl * IS
. . . S Selected Items Ctrl+S roject From Existing Code...
in this tutorlal.) Save Selected ltems As... o

¥ Save Al Ctrl+ Shift+S Studio 2
Visual §

NEW T

Export Template

Source Control 3
Page Setup... Unity
Print.. CtrleP Unity
Account Settings... Afew
Unity. T,
Recent Files » the rich

B Eit Alt+F4 NEW TH

From the File menu, select Project.

When the New Project dialog window appears, select the Template that corresponds
to your version of RecurDyn.

Note: You must use the ProcessNet project that is compatible with your version of RecurDyn.
If the version is incorrect, then ProcessNet may not execute properly. The New Project dialog
window shows all the templates that are compatible with the installed version of RecurDyn.




4.

5.
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Select Templates->Visual C#->RecurDyn. And then, click the <RecurDyn
Version> ProcessNet CSharp Project icon.

New Project ?

b Recent NET Framework 4.5.2 ~ Sort by: Default
4 Installed

. @D vers ProcessNet Csharp Project Visual = Type: Visual G
4 Templates <No description available>
4 Visual C* w VIR3 ProcessNet CSharp Project Visual C#
b Windows
Web w VR4 ProcessNet CSharp Project Visual C#
Android
Cloud
Extensibility
i0S
LightSwitch
Office/SharePoint
[RecurDyn)
Silverlight
Test
WCF
Workflow
b Visual Basic
Visual F#
b Visual C++
SQL Server

Click h i f s
b Online Click here to go online and find templates

Name: Excavator

i —— 2 L e LA e g e ( Browse...

Solution: Create new solution

Solution name: Excavator [V Create directory for solution
[T] Add to Source Control

Excavator Project will be created with setting Name, Location, and Solution name as
shown in the above figure.

B P20 ] oww - e,

Salution Explorer
B o--08B LR

131 Sehution 4WD_Loader (1 project)
A& oader

Project Editor Window

4D Losdercsproj

Project Window

- /| @ 0kmees | 4 0Wamings | @) OMessages | Buid + InteliSense

Code Description

Message Window

configuration, sbout
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It contains four areas that let you:
* Project Editor Window - Write and edit code and design interface objects.
* Project Explorer - Get an organized view of your project and its files.

* Properties window - View and edit the properties of objects you selected in the
Project Editor window or Project Explorer

» Message window -View information that is generated as you build and run your
code, such as errors in your code.

You are now ready to start developing your first ProcessNet application.
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Chapter

Creating a Dialog Window

In this chapter, you will learn how to create a dialog window and configure its layout. This
includes designing the layout of the dialog window and adding the code to call the dialog
window in ProcessNet.

Task Objectives

To learn how to create a dialog window and a function to call the dialog window in
ProcessNet.

Estimated Time to Complete this Task

15 minutes

10
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Creating a Dialog Window

To create a dialog window:

1. In the Visual Studio, right-click
the Project Explorer pane.

2. Click Add - New Item.

3. When the Add New Item dialog
window appears, click the
Windows Form icon, and then
type ExcavatorDialog in the name
field.

4. Click Add.

4 Installed Sort by: Default

#

4 Visual C& Itemns

Solution Explorer
B o-sedmF-8

Search Solution Explorer (Ctrl+;)

Fal Solution ‘Excavator' (1 project)

> - Rebuild

boe Clean
View
Anslyze

Scopeto This
B! New Solution Explorer View
£ Show on Code Map

Add
B Manage NuGet Packages...
£} Set as StartUp Project

Debug

Solution Exg Source Control

C
Class Visual C# Items
Code f’;j
Data
#
General 0 Interface Visual C# Items
b Web
Windows Forme Windows Form Visual C# Items
WPF
L] #
SQL Server .'.j User Control Visual C# tems
Workflow
2 | Component Class Visual C# tems
b Online b
(]
User Control (WP Visual CZ Items
o (e
T1o| AboutBox Visual CZ Items
q? ADO.NET Entity Data Model Visual CZ Items
?3 Application Configuration File Visual C# Items
Application Manifest File Visual C# Items
—cs
] Assembly Infermation File Visual C# Items
E Bitmap File Visual C# Items
L et 8 e
Click here to go online and find templates.
I Narme: ExcavatorDialog

Ctrl+Shift+A

New Folder
Reference...

Web Reference...

Search Installed Templates (Ctrl+E) P~

Type: Visual C# Items
A blank Windows Form

Add || Cancel |

5. ExcavatorDialog.cs[Design], a design window for Windows Form, appears in the

Visual Studio Project Editor pane.

11
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B4 Bavator - Microsot Vs Stuio TR ik L Ao B x
Fle Eft Vew Pmjea Buld Debig Team fomm Took Aihtnre Tet Anaboe Window Hep s B
B-G M9 [lowy -t b A

ing
FightTedzfe N
FightTel ehlsyout False

Erire Solution -/ D 0Enon | 4 0Wamings | @) 0Messages | Budd - IelSense - n ra

StartPosition WindowsDefaultLocation

Tea ExcavatorDisiog

6. Click the ExcavatorDialog dialog window in the top left corner of the screen.

The information about ExcavatorDialog appears in the Properties pane in the
bottom right corner of the screen. In the Properties pane, set the Size to 480, 800.

8. Also, set the FromBorderStyle to FixedToolWindow.

ExcavatorDialog Systern.Windows.Forms.Form -
§ 5
MinimizeBox True e
Minimumb5ize 00
Opacity 100%%
Padding 0,0,0,0
RightToleft Mo
RightToleftLayout False
Showlcon True
ShowlnTaskbar True
g5 G |
SizeGripStyle Auto
StartPosition WindowsDefaultLocation
Tag
Text ExcavatorDialog
TopMost False
Transparencykey |:|
UseWaitCursor Falze
Window5tate Mormal
-
Size

The size of the control in pixels.

12
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ForeColor ControlText
FixedToolWindow v ]
HelpButton False

lcon F_il (lcon)

9. Move the cursor to the Toolb(# Toclbox in the
top left corner of the screen. You will see the menu
with which you can add a dialog window, button, and

Toolbox

Search Toolbox

other control functions. Panel
Note: If you cannot see the Toolbox, open the View menu, p?rforma"cecwnter
and then click Toolbox or press Ctrl + Alt + X.
PrintDialog

10. In the Common Controls list, select PictureBox,
and then drag and drop the Label in the top left
corner of the dialog window that you want to design.

PrintDocument
PrintPreviewControl
11. Select the PictureBox you created. PrintPreviewDialog
Process

BT anh bR EE

12. As shown in the figure below, in the Properties pane in the bottom right corner of the
screen, click the ... button to the right of the Image row.

The Select Resource dialog window appears.

Properties *aOx
pictureBox1 System Windows.Forms.PictureBox

=N “] 2 ‘ I Resource context
Ancher Top, Left “ () Local resource:
BackColor D Control
Backgroundimage D (none) Import...
Backgroundlmagelayout Tile

Project resource file:
BorderStyle None ® .

ContextMenuStrip (none) | Resources.resx
Cursor Default
Dock None
Enabled True
Errorlmage El System.Drawing Bitmap
GenerateMember True
I ) o
Imagelocation
Initiallmage System.Drawing Bitmap .
@ Laratinn nn
Choose Image...
Image

The image displayed in the PictureBox.

13. In the Select Resource dialog window, select Local resource, and then click the
Import button.

13
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15.
16.

17.
18.

19.

20.

21.

22.
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When the Open dialog window appears, select the picture file to use. (For this tutorial,
use the Excavator_1.png file located in the

“<InstallDir>/Help/Tutorial/ProcessNet/General/Excavator/Excavator” directory.)
After confirming that the picture is correct, click the OK button.

In the Properties pane, set the SizeMode to AutoSize and type 0,0 in the Location
field.

Location 0,0
Locked False
Margin 3,333

Maximum5ize 0,0
Minimumsize 0,0
Modifiers Private
Padding 0,000
Size 460, 761
SizeMode AutoSize

Select the Toolbox.

In the Common Controls list, select Label, and then drag and drop the Label in the
top left corner of the dialog window that you want to design.

Select the Label you created. Then, in the Properties pane, type CAD File Path in the
Text field and type 12,17 in the Location field.

Location 12,17
Locked False
Margin 3,030

Maximumsize 00
MinimumSize 0,0
Modifiers Private
Padding 0,000
RightToLeft No
Size 83, 12
Tablndex 1
Tag
Text CAD File Path

Select the Toolbox again. Then, click and drag the TextBox from the Common
Controls list and drop it to the right of the Label.

In the Properties pane for Textbox1 in the top right corner of the window, type 108,
14 in the Location field, tbPath in the Name field, and 260,21 in the Size field.

For Buttonl1, Button2, TextBox1, TextBox2, TextBox3, TextBox4, TextBox5, and
TextBox6, change the Text and Name values as described in the procedure above by
referring to the following table.

Dialog Element Text Name Location Size
Button1 btSearchPath 373,12 75, 23
Button2 Import btImport 15, 53 433, 23
TextBox1 HydraulicCylin  tbHydraulicCylinder 161, 251 110, 20

der

14
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TextBox2 DipperStick tbDipperStick 68, 364 110, 20
TextBox3 Crank_Link_L tbCrank_Link_L 312, 402 100, 20
TextBox4 Crank_Link_R tbCrank_Link_R 170, 468 100, 20
TextBox5 BktTrLink tbBktTrLink 243, 428 100, 20
TextBox6 Bucket_Joint  tbBucket_Joint 282, 508 100, 20
TextBox7 Bucket tbBucket 258, 614 100, 20

23. After setting all of the values described above, the dialog window should resemble the
figure below.

24. Open the File menu and click Save ExcavatorDialog.cs to save the file.

ExcavatorDialog @

CAD File Path

Import

DipperStick

Note: The size or location of the dialog window may differ depending on the PC environment.

15
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Configuring the Initial Settings of the Dialog Window

The previous procedure configured the appearance of the dialog window. Now, you must add
variables to the dialog window to define what values users can enter and the event generated
when users click a button. Also, you will also learn how to use the ProcessNet function in the

dialog window.

To configure the initial settings of the dialog

window: Project Explorer
= | & 2| EE
1. In the Project Explorer, right-click 5 Excavator
ExcavatorDialog.cs. In the context menu, #- 5 Properties

. |«9 References

=

click View Code to display the source code
for ExcavatorDialog.cs in the Project
Editor window.

| Recurdyn

- ] Thishpplication.cs
o] [ res

2. In the Project Editor window, enter the SRl ExcavatorDialea e

. . . . - i Open
variables to be used in the dialog window. B Excavator 1 7
i ] Excavaton Open With...

*  FunctionBay.RecurDyn.ProcessNet
provides the reference information to
use in ProcessNet functions.

[Z] View Code |
] View Designer

= IApplication is the interface used to
recognize RecurDyn.

* The strFilePath and StrExcavatorPartName are the string to display and
the path of the CAD file or subsystem file to use when Excavator does not
exist, respectively.

using System.Windows.Forms;
using FunctionBay.RecurDyn.ProcessNet;

namespace Excavator
{
public partial class ExcavatorDialog : Form
{
IApplication application;
string strFilePath;
string[,] strExcavatorPartName = new string[7, 2];
public ExcavatorDialog(IApplication app)
{
InitializeComponent();
application = app;

3. In the Project Explorer, right-click ExcavatorDialog.cs, and then click View
Designer to display the dialog window you created in

the previous procedure. T T
4. In the dialog window, double-click the ... button to T —
create the function to call when the user double-clicks | " %o
a button. R G
booc Thishpplicatiol Wit
5. Insert the following code to create the function = =
automatically. - V:Dggm o
Scope to This

16
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*» This code imports the folder path from the Folder Dialog window.

= Click the ... button to execute the btSearchPatch_Click() function and create the
Folder Dialog window.

private void btSearchPath_Click(object sender, EventArgs e)

FolderBrowserDialog dialog = new FolderBrowserDialog();
dialog.ShowDialog();
this.tbPath.Text = dialog.SelectedPath;

¥
6. In the Project Explorer, right-click ExcavatorDialog.cs, and then click View
Designer. In the dialog window, double-click the Import button to create the
btImport_Click() function.
7. Under the btImport_Click () function, create a new function called UpdateDB() and

enter the following code.

» The UpdateDB() function stores the variable entered in the textbox of the dialog
window.

* The This.tbPath.text procedure retrieves the value entered in the textbox
named tbPath..

= The strExcavatorPartName is a two-dimensional array that saves the name and
path of a CAD file or subsystem file.

private void UpdateDB()
{
strFilePath = this.tbPath.Text;
strExcavatorPartName[0, 0] = this.tbDipperStick.Text.ToString();
strExcavatorPartName[0, 1] = strFilePath + @"\" + this.tbDipperStick.Text.ToString() + ".x_t";
strExcavatorPartName[1, 0] = this.tbCrank_Link_L.Text.ToString();
strExcavatorPartName[1, 1] = strFilePath + @"\" + this.tbCrank_Link_L.Text.ToString() + ".x_t";
strExcavatorPartName[2, 0] = this.tbCrank_Link_R.Text.ToString();
strExcavatorPartName[2, 1] = strFilePath + @"\" + this.tbCrank_Link_R.Text.ToString() + ".x_t";
strExcavatorPartName[3, 0] = this.tbBucket.Text.ToString();
strExcavatorPartName[3, 1] = strFilePath + @"\" + this.tbBucket.Text.ToString() + ".x_t";
strExcavatorPartName[4, 0] = this.tbBucket_Joint.Text.ToString();
strExcavatorPartName[4, 1] = strFilePath + @"\" + this.tbBucket_Joint.Text.ToString() + ".x_t";
strExcavatorPartName[5, 0] = this.tbBktTrLink.Text.ToString();
strExcavatorPartName[5, 1] = strFilePath + @"\" + this.tbBktTrLink.Text.ToString() + ".rdsb";
strExcavatorPartName[6, 0] = this.tbHydraulicCylinder.Text.ToString();
strExcavatorPartName[6, 1] = strFilePath + @"\" + this.tbHydraulicCylinder.Text.ToString() +
".rdsb";
¥

8.

Insert the following code to create the function automatically.

= The code executes the UpdateDB() function when a user clicks the Import button
in the dialog window.

private void btImport_Click(object sender, EventArgs e)
{

b

UpdateDB();

9.

In the File menu, click Save ExcavatorDialog.cs to save the file.

17
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Displaying a Dialog Window when the User Runs the
Application

This section teaches you how to display a dialog window when a user runs the ProcessNet
application in RecurDyn and how to make a dialog window dependent on RecurDyn.

To display a dialog window when a user runs the application:

1. In the Project Explorer, double-click ThisApplication.cs.

2. In the ThisApplication.cs file, delete the HelloProcessNet() and
CreateBodyExample() functions marked with strikethroughs, as shown below. (These

functions are generated automatically as an example.)

3. Write the Run() function shown below.
= This function creates a new instance of ExcavatorDialog.

= It delivers the values of Application and MainWindow to the ExcavatorDialog
class.

Note: The Application and MainWindow values must be delivered to this class to use
ProcessNet methods in WinForms.

public void Run()
{

ExcavatorDialog DialogRun = new ExcavatorDialog(application);
DialogRun.ShowDialog();

4. In the File menu, click Save ThisApplication.cs to save the file.

18
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Testing a Dialog Window

In this section, you will test whether the application created above works properly.

To run the application:

1. Check if any errors or warnings appear in the Error List pane at the bottom of the IDE

window. If there are any errors or warnings, correct the problems. In the Build menu,
click Build Solution.

Build | Debug Team Format Tools _ Archit
o 2% Build Solution F6
I Rebuild Solution
Clean Solution
i Run Code Analysis on Solution Alt+F11
Y Build Excavator Shift+F6

Rebuild Excavator

Clean Excavator

Run Code Analysis on Excavator
Batch Build...

Configuration Manager...

2. In RecurDyn, on the Customize tab, in the ProcessNet(General) group, click Run.

&
_w 1'

Run RegisterDLL

ProcessMet(General)

3. In the tree in the lower half of the ProcessNet Manager dialog window, click Run
under Excavator.

4. In the ProcessNet Manager dialog window, click the Run button.

19



5. The created dialog window appears.
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% ProcessNet Manager V9R4

~ProcessNet Assembly

X

Run

D15\Projects\Excavator\Excavator\bin\x64\Debug\Excavator.dil @

~ProcessNet Assembly

|

CAD File Path

HydraulicCyinder |

6. Once you confirm that the application runs properly, close the dialog window.

7.

Close the ProcessNet Manager dialog window.

20
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Chapter

Automatic Model Generation
through Code

Task Objectives

In this chapter, you will create a new class and write a ProcessNet function under that class.
Then, you will learn how to call this function in the dialog window created in the previous
chapter.

Estimated Time to Complete this Task

30 minutes

21
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Creating a New Class

Thls SeCtlon teaChes you hOW to Create a new CIaSS ' | Project | Build Debug Team  Tools  Architecture
and enter a ProcessNet function under that class. . *5  AddWindows Form..
H ﬂ Add User Control... i

*1  Add Component...
*s  Add Class... Shift+Alt+C

To create a new class: to ,
=4 " Add New Data Source...
, . . . | i3 add Newktem.. Ctrl+Shift+ A
1. In the Visual Studio, click Project - Add New hErrTr—— Y

Item.

Exclude From Project

2. When the Add New Item dialog window D el
appears, select Class in the Templates pane Add Reference..
and type PNetFunction in the Name field. fdd Serviee Reference..
Then, click the Add button.

4 Installed Sort by: | Default - s Search Installed Templates (Ctrl+E) L~
«+ EEEEEERE ‘l‘—;]cx Class Visual C# frems | Type: Visual C# Ttems
Ende An empty class definition
ata
General 0 Interface Visual C# Items
b Web
Windows Forms Windows Form Visual C# Items
WPF
L]
SQL Server ;j User Control Visual C# Items
Waorkflow
s | Component Class Visual C# Items
B Online =
[ ) )
User Control (WP Visual C# Items
M wen
About Box Visual C# Items
@ ADO.NET Entity Data Model Visual C# Items
?g Application Configuration File Visual C# Items
Application Manifest File Visual C# Items
=
] Assembly Information File Visual C# tems
E Bitmap File Visual C# Items
e e Vot ;e
Click here te go online and find ternplates.
I Name: PMetFunction I

add || Cancel |

3. When the PNetFunction.cs appears in the Project Editor pane, enter the following
code. This code resets the basic variables used to execute a ProcessNet function.

= IApplication: Used to recognize RecurDyn

= IModelDocument: A model document used in RecurDyn
= ISubsystem: A subsystem used in the model document
= IReferenceFrame: A reference frame of RecurDyn

= IPlotDocument: A RecurDyn plot document

22



DIPPER STICK WITH BUCKET TUTORIAL (PROCESSNET GENERAL)

using FunctionBay.RecurDyn.ProcessNet;
namespace Excavator
{
class PNetFunction
{
static public IApplication application;
public IModelDocument modelDocument = null;
public IPlotDocument plotDocument = null;
public ISubSystem model = null;

public IReferenceFrame refFramel = null;
public IReferenceFrame refFrame2 = null;

public PNetFunction(IApplication app)
{

b

application = app;

4. In the File menu, click Save PNetFunction.cs to save the file.

Creating a Model

In this section, you will learn how to create an Excavator model automatically.
To import a body:

1. Write a code that creates an Excavator model using a CAD file and Subsystem file.

2. Create the following Import() function.

public void Import(string[,] strExcavatorPartName)
{
¥
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3. Then, insert the following variable declaration in the Import() function.

modelDocument = application.ActiveModelDocument;
model = modelDocument.Model;

refFramel = modelDocument.CreateReferenceFrame();
refFramel.SetOrigin(0, 0, 0);
refFrame2 = modelDocument.CreateReferenceFrame();
refFrame2.SetOrigin(0, 0, 0);

4. After the variable declaration, add the following loop to import the *.x_t and *.rdsb files.
The *.x_t files are the CAD files for the respective parts of the model and the *.rdsb files

are the subsystem files.

* FileImport() imports the CAD and subsystem files.

= Crank Link R creates a marker without importing the CAD files. So, a continue

statement is used to go to the next loop.

for(int iCount = 0; iCount < 7; iCount++)

{
if( iCount == 2)
continue;
model.FileImport(strExcavatorPartName[iCount,1]);
b

5. Enter the following code to use the SubSystemCollection property to compose a list of
subsystems in the model and then declares the subsystems as Sub01, Sub02, and so

on.

ISubSystemCollection SubCollection01 = model.SubSystemCollection;
ISubSystem Sub01 = SubCollection01[0];
ISubSystem Sub02 = SubCollection01[1];

6. Use the GetEntity() function to search the imported body.

= The GetEntity() function searches the entities in RecurDyn.

= Basically, IGeneric is returned for the function. The function can perform type

conversion according to the type of entity you want.

IBody BodyDipperStick = model.GetEntity(strExcavatorPartName[0,0]) as IBody;
IBody BodyCrankLinkL = model.GetEntity(strExcavatorPartName[1, 0]) as IBody;
IBody BodyBucket = model.GetEntity(strExcavatorPartName[3, 0]) as IBody;
IBody BodyJoint = model.GetEntity(strExcavatorPartName[4, 0]) as IBody;

IBody BodyBktTrLink_CylRod_Cylinder = Sub01.GetEntity("BktTrLink_CylRod_Cylinder") as IBody;
IBody BodyBktTrLink_Bucket_BktTrLink_Cylinder = Sub01.GetEntity("Bucket_BktTrLink_Cylinder") as
IBody;

IBody BodyBktTrLink_Right_Link = Sub01.GetEntity("Right_Link") as IBody;

IBody BodyHydraulicCylinder_Cylinder = Sub02.GetEntity("Cylinder") as IBody;

IBody BodyHydraulicCylinder_Rod = Sub02.GetEntity("Rod") as IBody;

I1Body BodySub02Mother = Sub02.GetEntity("MotherBody") as IBody;
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7. Enter the following code to generate a marker in the link body called Crank_Link_R and

the Bucket_Joint body.

= Crank_Link_R creates a marker instead of importing the CAD file so that you can

control the model posture by entering the PP in its second variable.

IBody BodyCrankLinkR = model.CreateBodyLinkWithRadius(strExcavatorPartName[2, 0], new double[]
{ 5506.1017, -495.8525, 2231.9958 }, new double[] { 5606.1017, -495.8525, 2231.9958 },100,100, 35);
BodyCrankLinkR.Graphic.Color = 26367;

refFramel.SetOrigin(6060.3717, -207.8525, 1993.4767);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 180, 90, 90);
IMarker MarkerO1 = BodyJoint.CreateMarker("Markerl", refFramel);

8. Declare the ground of the assembly mode as bodyground.

IBody BodyGround = model.Ground;

9. Create a dummy body.

refFramel.SetOrigin(5579.2685, -207.8525, 62.560441);

IBody BodyDummyBucketTip = model.CreateBodyEllipsoid("BucketTip", refFramel, 50, 50, 50);
refFramel.SetOrigin(6100, -207.8525, 4200);

IBody BodyDummyDrivingForceBody = Sub02.CreateBodyEllipsoid("DrivingForceBody", refFramel, 50, 50,
50);

10. In the File menu, click Save PNetFunction.cs to save the file.
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To create a SubEntity:

In this section, you will create the SubEntity to be used in the Excavator model.

2. Add the following code to create the PVs in the Import() function created in the previous
procedure.

(All the codes from creating the SubEntity to creating the variable equations should be
added consecutively with the same indentation inside the Import() function.)

IParametricValue PV_DeltaCrankLength = model.CreateParametricValue("PV_DeltaCrankLength", 0);
IParametricValue PV_BucketlointAngleDeg = model.CreateParametricValue("PV_BucketlointAngleDeg", 0);
IParametricValue PV_BucketlointAngle = model.CreateParametricValue("PV_BucketlointAngle", 0);
IParametricValue PV_BktTrLink_CylRod_X = model.CreateParametricValue("PV_BktTrLink_CylRod_X", 0);
IParametricValue PV_BktTrLink_CylRod_Z = model.CreateParametricValue("PV_BktTrLink_CylRod_Z", 0);
IParametricValue PV_BucketlointOriginX = model.CreateParametricValue("PV_BucketlointOriginX", 0);
IParametricValue PV_BucketlointOriginZ = model.CreateParametricValue("PV_BucketlointOriginZ", 0);
IParametricValue PV_Cyl_Amplitude = model.CreateParametricValue("PV_Cyl_Amplitude", 350);

3. Add a code that creates the following expressions under the code that creates the PVs.

IExpression Ex_Deg2Rad = model.CreateExpression("Ex_Deg2Rad", "PV_BucketlointAngleDeg*PI1/180");
IExpression Ex_BktTrLink_CylRod_X = model.CreateExpression("Ex_BktTrLink_CylRod_X",
"C0S(0.291724-AC0OS(((704.58305+PV_DeltaCrankLength)*(704.58305+PV_DeltaCrankLength)-
10996911)/(-10963694)))*965.471+SIN(0.291724-
ACOS(((704.58305+PV_DeltaCrankLength)*(704.58305+PV_DeltaCrankLength)-10996911)/(-
10963694)))*(-2034.522)+5139.0782");

IExpression Ex_BktTrLink_CylRod_Z = model.CreateExpression("Ex_BktTrLink_CylRod_Z", "-
SIN(0.291724-ACOS(((704.58305+PV_DeltaCrankLength)*(704.58305+PV_DeltaCrankLength)-
10996911)/(-10963694)))*965.471+C0S(0.291724-
ACOS(((704.58305+PV_DeltaCrankLength)*(704.58305+PV_DeltaCrankLength)-10996911)/(-
10963694)))*(-2034.522)+4638.4021");

IExpression Ex_BucketJointOriginX = model.CreateExpression("Ex_BucketJointOriginX", "(1-
COS(PV_BucketlointAngle))*6191.0835-SIN(PV_BucketlointAngle)*1340.8818");

IExpression Ex_BucketJointOriginZ = model.CreateExpression("Ex_BucketJointOriginZ",
"SIN(PV_BucketlointAngle)*6191.0835+(1-COS(PV_BucketJointAngle))*1340.8818");
IExpression Ex_BucketTipLoad = model.CreateExpression("Ex_BucketTipLoad", "0");

IExpression Ex_DrivingForce = Sub02.CreateExpression("Ex_DrivingForce", "0");
Ex_DrivingForce.Arguments = new string[] { "Cylinder.Markerl@HydraulicCylinder",
"Rod.Markerl@HydraulicCylinder" };

Ex_DrivingForce.Text = "FZ(1,2,2)";

4. Add a code that generates values for the PVs under the code that creates each
expression.

After creating an expression, enter the values for the PVs. When the following code
is executed, the values of the PVs change to the expressions shown below.
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Parametric Value List Parametric Walue List
Parametric Valucs Parametric values
Mo | DP Mame Value Comment - No | DP ‘ Name Value Comment -
1 |_ PV_DeltaCrankLength 0 E A 1 |— PV_DeltaCrankLength 0. E A
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PV_BucketlointAngle.Text = "Ex_Deg2Rad";
PV_BktTrLink_CylRod_X.Text = "Ex_BktTrLink_CylRod_X";
PV_BktTrLink_CylRod_Z.Text = "Ex_BktTrLink_CylRod_Z";
PV_BucketJointOriginX.Text = "Ex_BucketJointOriginX";
PV_BucketlointOriginZ.Text = "Ex_BucketJointOriginZ";

5. Once the values for PVs are set, add the following code to create PPs.

IParametricPoint PP_CrankL_BktTrLink = model.CreateParametricPointWithText("PP_CrankL_BktTrLink",
"PV_BktTrLink_CylRod_X,80.147498,PV_BktTrLink_CyIRod_Z", null);

IParametricPoint PP_Bucket_BktTrLink = model.CreateParametricPoint("PP_Bucket_BktTrLink", new double[] { O,
0, 0 }, null);

IParametricPoint PP_BktTrLink_Rod = model.CreateParametricPointWithText("PP_BktTrLink_Rod",
"PV_BktTrLink_CylRod_X,-207.85255,PV_BktTrLink_CylRod_Z", null);

IParametricPoint PP_DipperStick_Cyl = model.CreateParametricPoint("PP_DipperStick_Cyl", new double[]
{5139.0782, -207.85255, 4638.4021 }, null);

IParametricPoint PP_BucketJointOrigin = model.CreateParametricPointWithText("PP_BucketJointOrigin", "
PV_BucketJointOriginX,0.,PV_BucketlointOriginZ", null);

IParametricPoint PP_CrankR_BktTrLink = model.CreateParametricPointWithText("PP_CrankR_BktTrLink",
"PV_BktTrLink_CylRod_X,-495.8525, PV_BktTrLink_CylRod_Z", null);

PP_Bucket_BktTrLink.RefMarker = Marker01;

6. Under the code that creates the PPs, add the following code to create the PPCs and
PVCs.

IParametricPointConnector PPC_Bucket_BktTrLink =
model.CreateParametricPointConnector("PPC_Bucket_BktTrLink");
PPC_Bucket_BktTrLink.Point.ParametricPoint = PP_Bucket BktTrLink;

IParametricPointConnector PPC_BktTrLink_CylRod =
model.CreateParametricPointConnector("PPC_BktTrLink_CylRod");
PPC_BktTrLink_CylRod.Point.ParametricPoint = PP_BktTrLink_Rod;

IParametricPointConnector PPC_Cyl_End = model.CreateParametricPointConnector("PPC_Cyl_End");
PPC_Cyl_End.Point.ParametricPoint = PP_DipperStick_Cyl;

IParametricPointConnector PPC_Rod_End = model.CreateParametricPointConnector("PPC_Rod_End");
PPC_Rod_End.Point.ParametricPoint = PP_BktTrLink_Rod;

IParametricValueConnector PVC_Cyl_Amplitude = model.CreateParametricValueConnector("PVC_Cyl_Amplitude");
PVC_Cyl_Amplitude.Value.ParametricValue = PV_Cyl_Amplitude;
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7. Under the code that creates the PPCs and PVCs, add the following code to change the
second point and normal direction of Crank_Link_R.

IGeometryLink GeoLinkl = BodyCrankLinkR.GetEntity("Link1") as IGeometryLink;
Geolink1.SecondParametricPoint = PP_CrankR_BktTrLink;
Geolinkl.SetNormalDirection(0, 1, 0);

8. In the File menu, click Save PNetFunction.cs to save the file.
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To create a joint:

1. In this section, you will create the joints to be used in the Excavator model.

In the Import() function created in the previous procedure, add the following code to create
the fixed joints.

refFramel.SetOrigin(4440.16, -387.85255, 4768.1811);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 0, 90, 0);

IJointFixed FixedJoint_Dipper_Ground = model.CreateJointFixed("Fixed_Dipper_Ground", BodyGround,
BodyDipperStick, refFramel);

refFrame1.SetOrigin(6191.0835, -207.8525, 1340.8818);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZYX, 0, 0, 0);

IJointFixed FixedJoint_Bucket_Bucketloint = model.CreatelointFixed("Fixed_Bucket_Bucketloint", BodyBucket,
BodylJoint, refFramel);

FixedJoint_Bucket_Bucketloint.BaseMarker.RefFrame.EulerAngle.Beta.ParametricValue = PV_BucketlointAngle;

refFramel.SetOrigin(5679.2685, -207.8525, 62.560441);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_7ZXZ, 0, 90, 0);

IJointFixed FixedJoint_BucketTip_Bucket = model.CreateJointFixed("Fixed_BucketTip_Bucket",
BodyDummyBucketTip, BodyBucket, refFramel);

refFramel.SetOrigin(6100, -207.8525, 4200);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 0, 0, 0);

IJointFixed FixedJoint_DrivingForceBody = model.CreateJointFixed("Fixed_DrivingForceBody", BodyGround,
BodyDummyDrivingForceBody, refFramel);
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2. Add the following code to create the revolute joints.

refFramel.SetOrigin(5506.1017, 62.147449, 2231.9959);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 180, 90, 90);

IJointRevolute Revloint_Dipper_Crank_L = model.CreatelointRevolute("Rev_Dipper_Crank_L", BodyCrankLinkL,
BodyDipperStick, refFramel);

refFramel.SetOrigin(5504.8615, -207.8525, 1879.9098);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 180, 90, 90);

IJointRevolute Revloint_Dipper_Bucket = model.CreatelointRevolute("Rev_Dipper_Bucket", BodyDipperStick,
BodyBucket, refFramel);

refFramel.0rigin.ParametricPoint = PP_CrankL_BktTrLink;
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 180, 90, 90);

IJointRevolute Revloint_BktTrLink_Crank_L = model.CreateJointRevolute("Rev_BktTrLink_Crank_L",
BodyCrankLinkL, BodyBktTrLink_CylRod_Cylinder, refFramel);
RevJoint_BktTrLink_Crank_L.ActionMarker.RefFrame.Origin.ParametricPoint = PP_CrankL_BktTrLink;
Revloint_BktTrLink_Crank_L.BaseMarker.RefFrame.Origin.ParametricPoint = PP_CrankL_BktTrLink;

refFramel.0rigin.ParametricPoint = PP_Bucket_BktTrLink;
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 180, 90, 90);

IJointRevolute Revloint_Bucket_BktTrLink = model.CreateJointRevolute("Rev_Bucket_BktTrLink", BodyJoint,
BodyBktTrLink_Bucket_BktTrLink_Cylinder, refFramel);
RevJoint_Bucket_BktTrLink.ActionMarker.RefFrame.Origin.ParametricPoint = PP_Bucket BKktTrLink;
RevJoint_Bucket_BktTrLink.BaseMarker.RefFrame.Origin.ParametricPoint = PP_Bucket_BktTrLink;

refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 0, 90, 0);

IJointRevolute Revloint_Dipper_Crank_R = model.CreateJointRevolute("Rev_Dipper_Crank_R", BodyCrankLinkR,
BodyBktTrLink_Right_Link, refFramel);
Revloint_Dipper_Crank_R.ActionMarker.RefFrame.Origin.ParametricPoint = PP_CrankR_BktTrLink;
Revloint_Dipper_Crank_R.BaseMarker.RefFrame.Origin.ParametricPoint = PP_CrankR_BktTrLink;

refFramel.SetOrigin(5506.1017, -477.85255, 2231.9959);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 0,90,0);

IJointRevolute Revloint7 = model.CreateJointRevolute("Revloint3", BodyDipperStick, BodyCrankLinkR,
refFramel);

refFramel.0rigin.ParametricPoint = PP_DipperStick_Cyl;
IJointRevolute Rev]oint8 = model.CreateJointRevolute("Revloint4", BodyDipperStick,
BodyHydraulicCylinder_Cylinder, refFramel);

refFramel.0rigin.ParametricPoint = PP_BktTrLink_Rod;
IJointRevolute Revloint9 = model.CreateJointRevolute("Revoint5", BodyHydraulicCylinder_Rod,
BodyBktTrLink_CylRod_Cylinder, refFramel);

3. In the File menu, click Save PNetFunction.cs to save the file.
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To create a force:

1. In this section, you will create the Force to be used in the Excavator model.

2. Under the code you entered in the previous procedure, enter the following code to
create the force.

refFramel.SetOrigin(5679.2685, -207.8525, 62.560441);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 90,90,-90);
refFrame2.SetOrigin(5579.2685, -207.8525, 62.560441);
refFrame2.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 90, 90, -90);

IForceAxial ForAxiall = model.CreateForceAxial("BucketTipLoad", BodyDummyBucketTip, BodyBucket, refFrame2,
refFramel);

ForAxiall.ForceDisplay = ForceDisplay.Action;

ForAxiall.Expression = Ex_BucketTipLoad;

refFramel.SetOrigin(6400, -207.8525, 4200);
refFramel.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 0, 90, 0);
IMarker Marker02 = Sub02.CreateMarker("Markerl", BodySub02Mother, refFramel);

refFrame2.SetOrigin(6100, -207.8525, 4200);
refFrame2.SetEulerAngleDegree(EulerAngle.EulerAngle_ZXZ, 0, 90, 0);

IForceAxial ForceAxial02 = Sub02.CreateForceAxial("Ex_Rqg_CylPow", BodyDummyDrivingForceBody,
BodySub02Mother, refFrame2, refFramel);

ForceAxial02.ForceDisplay = ForceDisplay.Base;

3. In the File menu, click Save PNetFunction.cs to save the file.
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To create a variable equation:
1. In this section, you will create the variable equations and requests to be used in the
Excavator model.

2. Under the code you entered in the previous procedure, enter the following code to
create the variable equations and requests.

= The model.Redraw() function redraws the graphics in the Working pane.

IExpression Ex_MaxPosRot = model.CreateExpression("Ex_MaxPosRot", "0");

IVariableEquation VE_MaxPosRot = model.CreateVariableEquation("VE_MaxPosRot", Ex_MaxPosRot);
Ex_MaxPosRot.Arguments = new string[] { "Bucket.Marker3", "DipperStick.Marker3", "VE_MaxPosRot" };
Ex_MaxPosRot.Text = "IF(VARVAL(3)-AZ(1,2):AZ(1,2),VARVAL(3),VARVAL(3))";

IExpression Ex_MaxNegRot = model.CreateExpression("Ex_MaxNegRot", "0");

IVariableEquation VE_MaxNegRot = model.CreateVariableEquation("VE_MaxNegRot", Ex_MaxNegRot);
Ex_MaxNegRot.Arguments = new string[] { "Bucket.Marker3", "DipperStick.Marker3", "VE_MaxNegRot" };
Ex_MaxNegRot.Text = "IF(AZ(1,2)-VARVAL(3):AZ(1,2),VARVAL(3),VARVAL(3))";

Ex_BucketTipLoad.Arguments = new string[] { "Bucket.Marker3", "DipperStick.Marker3" };
Ex_BucketTipLoad.Text = "50000*IF(WZ(1,2,2):0,0,1)";

IExpression Ex_CylinderPower = model.CreateExpression("Ex_CylinderPower", "0");
Ex_CylinderPower.Arguments = new string[] { "Ground.Marker2",

"DrivingForceBody.Markerl @HydraulicCylinder", "Rod.Marker1@HydraulicCylinder",
"Cylinder.Markerl@HydraulicCylinder" };

Ex_CylinderPower.Text = "FX(1,2,2)*VZ(3,4,4)";

IRequestExpression ExRg_CylPow = Sub02.CreateRequestExpression("ExRq_CylPow", Ex_CylinderPower,
Ex_MaxPosRot, null, null, null, null);

model.Redraw();

In the File menu, click Save PNetFunction.cs to save the file.

In the Build menu, click Build Excavator to execute the build. Check if any errors or
warnings appear in the Error List pane at the bottom of the IDE window. If there are
any errors or warnings, correct the problems.
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Linking a Function to the Dialog Window

In this section, you will learn how to call the Import() function when the user clicks the
Import button in the dialog window.

To link a function to a dialog window:

1. In the Project Explorer, right-click ExcavatorDialog.cs.
2. In the context menu, click View Code.
3. Enter the following code. (Enter the bold text.)

= Create an instance of PNetFunction to use the Import function.

public partial class ExcavatorDialog : Form
{
IApplication application;
string strFilePath;
string[,] strExcavatorPartName = new string[7, 2];
PNetFunction Function;

public ExcavatorDialog(IApplication app)

{

InitializeComponent();

application = app;

Function = new PNetFunction(application);
}

4. In the btImport_Click() function, enter the following code to use the PNetFuction
instance to call the Import() function. (Enter the bold text.)

private void btImport_Click(object sender, EventArgs e)
{
UpdateDB();
Function.Import(strExcavatorPartName);

5. In the File menu, click Save ExcavatorDialog.cs to save the file.
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Testing a Dialog Window

In this section, you will test whether the application you created works properly.

To run the application:

1.

q S e

10.

11.

In the Build menu, click Build Solution. Check if any errors or warnings appear in the
Error List pane at the bottom of the IDE window. If there are any errors or warnings,
correct the problems.

In RecurDyn, on the Customize tab, in the ProcessNet(General) group, click Run.

In the tree in the lower half of the ProcessNet Manager dialog window, click Run
under Excavator.

In the ProcessNet Manager dialog window, click the Run button.

The dialog window shown on the right appears.

In the dialog window, click the ... button.

CADFile Fath ||

When the Browse For Folder dialog window E,::EFU,ME, ‘
appears, specify the path where the file to import
exists. (For this tutorial, the file is located in the

“<InstallDir>/Help /Tutorial /ProcessNet v @ This pC "
/General /Excavator /Excavator” directory.) o
. . Downloads
Once you confirm that the file path has been ;,mweo}
entered in the CAD File Path, click the Import Z IWSEUUI“(“EUJ -
button. Ij’) Music ’
&= Pictures
The Excavator model appears automatically, as B videos
shown below. . 5

Click the x button in the top right corner of the Mok New Folder Cancel

dialog window to close the ExcavatorDialog
window.

Close the ProcessNet Manager dialog window.
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Chapter

Analyzing a Model

Task Objectives

In this chapter, you will create a function that applies the values of an entity to the model
when the user changes them in the dialog window and learn how to perform model analysis
in the dialog window.

Estimated Time to Complete this Task

10 minutes
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Editing the Layout of the Dialog Window

In this section, you will add a text box and a button to the dialog window so that users can
perform model analysis and plotting from the dialog window.

To edit the layout of the dialog window:
1. In the Project Explorer, double-click ExcavatorDialog.cs. The ExcavatorDialog.cs
dialog window appears in the Project Editor pane.

2. Select the ToolBox, and then add the following controls to the Common Controls list.
Then, change the values of these controls.

Dialog Element Text Name Location Size
Buttonl Simulation btSimulation 292, 90 75, 57
Button?2 Plot btPlot 373, 90 75, 57
TextBox1 tbBucketlointAngle 126, 92 154, 20
TextBox2 tbCrankLength 126, 127 154, 20
Labell BucketJoint_Angle IbBucketlointAngle 12, 95 83, 12
Label2 Crank_Length IbCrankLength 12, 130 83,12

3. In the File menu, click Save ExcavatorDialog.cs to save the file.

ExcavatorDialog [ = |

CAD File Path

Import

BucketJoint_Angle
Simulation Plat
CAD File Path

HydraulicCylinder

DipperStick

7"?5 Crank_Link_R
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Model Analysis Function

In this section, you will create a function that applies the length of a cylinder and the angle of
a bucket to the model when a user enters these values in the dialog window. The code will
then perform the model analysis when the user clicks the relevant button.

Model analysis function

1. In the Project Explorer, double-click PnetFunction.cs.

2. Under the Import() function created in the previous chapter, create a simulation
function.

= Enter the following code to change the PV values of PV_DeltaCrankLength and
PV_BucketlointAngleDeg using the Bucket Joint Angle and Crank Length values in
the dialog window.

public void Simulation(double[] dPVValue)

{
modelDocument = application.ActiveModelDocument;
model = modelDocument.Model;

IParametricValue PV_DeltaCrankLength = model.GetEntity("PV_DeltaCrankLength") as
IParametricValue;

IParametricValue PV_BucketlointAngleDeg = model.GetEntity("PV_BucketlointAngleDeg") as
IParametricValue;

PV_BucketJointAngleDeg.Value = dPVValue[0];

PV_DeltaCrankLength.Value = dPVValue[1];

model.Redraw();

modelDocument.ModelProperty.DynamicAnalysisProperty.SimulationStep.Value = 400;
modelDocument.ModelProperty.DynamicAnalysisProperty.SimulationTime.Value = 4;
modelDocument.Analysis(AnalysisMode.Dynamic);

3. In the Project Explorer, right-click ExcavatorDialog.cs, and then click View
Designer.

4. In the function created by double-clicking the Simulation button, enter the following
code.

private void btSimulation_Click(object sender, EventArgs e)

{
double dAngle = Convert.ToDouble(this.tbBucketJointAngle.Text);
double dLength = Convert.ToDouble(this.tbCrankLength.Text);
double[] dPVVAIue = new double[] { dAngle , dLength};
Function.Simulation(dPVVAlue);

5. In the File menu, click Save ExcavatorDialog.cs to save the file.
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Chapter

Creating a Plot Automatically

Task Objectives

In this chapter, you will learn the commands used to draw a plot in ProcessNet.

Estimated Time to Complete this Task

10 minutes
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Plot Function
To use the plot function: Dlot n x
1. In the Project Explorer, double-click

PnetFunction.cs.

2. Under the Simulation() function created in the
previous chapter, create the following Plot
function.

»  For GetPlotData, "EXCAVATOR" is the root of the plot. This root may differ
depending on the RecurDyn version.

jr-.lnints

= Use the ActivateView function to specify the view.

public void Plot()
{
modelDocument = application.ActiveModelDocument;
plotDocument = modelDocument.CreatePlotDocument(PlotDocType.WithRPLT);

double[] Time = plotDocument.GetPlotData("EXCAVATOR/TIME");
double[] dRelative = plotDocument.GetPlotData
("EXCAVATOR/Joints/Tralointl @HydraulicCylinder/Pos1_Relative");
double[] dDrivingForce = plotDocument.GetPlotData
("EXCAVATOR/Joints/Traloint1 @HydraulicCylinder/Driving_Force");
double[] dPos1_Relative = plotDocument.GetPlotData
("EXCAVATOR/Joints/Rev_Dipper_Bucket/Pos1_Relative");

plotDocument.PlotShowWindowType(ShowWindowOption.ShowAll);
plotDocument.LoadAnimation(PlotWindowPosition.LeftLower);

plotDocument.ActivateView(0, 0);
plotDocument.DrawPlot("Relative", Time, dRelative);
plotDocument.DrawPlot("DrivingForce", Time, dDrivingForce);
plotDocument.SimpleMathMultiply(0, 1, false, true);

plotDocument.ActivateView(0, 1);
plotDocument.DrawPlot("Post Relative", Time, dPos1_Relative);

3. In the Project Explorer, right-click ExcavatorDialog.cs, and then click View Designer.
4. Double-click the Plot button.

5. Under the created function, enter the following Plot function.

private void btPlot_Click(object sender, EventArgs e)
{

b

Function.Plot();

6. In the File menu, click Save ExcavatorDialog.cs to save the file.
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Testing the Created Application
In this section, you will test whether the application you created works properly.

To run the application:

1. In the Build menu, click Build Solution. Check if any errors or warnings appear in the
Error List pane at the bottom of the IDE window. If there are any errors or warnings,
correct the problems.

In RecurDyn, on the Customize tab, in the ProcessNet(General) group, click Run.

In the tree in the lower half of the ProcessNet Manager dialog window, click Run
under Excavator.
4. In the ProcessNet Manager dialog window, click the Run F— ‘
button. =

Buckerion fegle
Crank_Length

Simulsticn Pt

The dialog window shown on the right appears.

In the dialog window, type 0 for both the Bucketloint_Angle and
Crank_Length.

7. Click the Simulation button to confirm that the
PV_DeltaCrankLength and PV_BucketJointAngleDeg values
change according to the BucketJoint_Angle and Crank_Length
values you entered and that the model analysis is performed
according to the new values.

8. Once the analysis is complete, click the Plot button to draw a
plot shown below.

9. Close the ExcavatorDialog window.

10. Close the ProcessNet Manager dialog window.

Page 1 Page 1
B |e[El - | w5 FE 4P E] & Bkl RE PSS EEDPE K
| ~ Relative = DrivingForce = MULT(Relative, DnvmgFﬂme)‘
> >
X X

Modell Page 1
Time = Initial State

NSRRI EEE

U:II %
.lll No Data Available

d -8

Thanks for participating in this tutorial
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